It is currently 19 Feb 2018, 23:36

GIMP Python Fu ScriptsPancake or Cookie Script Fixed 2.8.16 up to 22 (Showcase | Slideshow)

Share your Python Fu scripts for GIMP here
User avatar
Issabella
Script Tester
View: Showcase | Slideshow
Topic Posts: 4/60
Posts: 1962
Joined: 19 Jan 2017, 11:42
Cash on hand: 17,162.78 GLP
Gender: Gal
Operating System: Windows
x 231
x 505
Spain

Re: Pancake or Cookie Script

Post#8 by Issabella » 31 May 2017, 16:10


I have this error message, animicule. I have Layer Effects installed.
Attachments
Captura_error.JPG
Captura_error.JPG # (21.19 KiB) Viewed 165 times (Watermarked | Thumbnail)
0 x



Issabella

Registered members enjoy ads-free content
User avatar
animicule

Script Coder
View: Showcase | Slideshow
Topic Posts: 38/60
Posts: 614
Joined: 10 Jan 2017, 15:25
Cash on hand: 148.06 GLP
Bank: 56,999.00 GLP
Gender: Guy
Location: South Dakota
Operating System: Windows
GIMP Version: 2.9.5
x 169
United States of America

Post#9 by animicule » 31 May 2017, 16:54


Issabella, thank you for finding the problem!

It needs another AnimStack script also. I have put a link on the 1st post to AnimStack.
It should run then.
0 x




User avatar
animicule

Script Coder
View: Showcase | Slideshow
Topic Posts: 38/60
Posts: 614
Joined: 10 Jan 2017, 15:25
Cash on hand: 148.06 GLP
Bank: 56,999.00 GLP
Gender: Guy
Location: South Dakota
Operating System: Windows
GIMP Version: 2.9.5
x 169
United States of America

Post#10 by animicule » 31 May 2017, 19:47


I think I should start renaming my script and plugins folders so gimp doesn't find them and final testing to make certain there
are no unexpected dependencies.
0 x




User avatar
tim
Administrator
View: Showcase | Slideshow
Topic Posts: 14/60
Posts: 2161
Joined: 26 Sep 2016, 00:16
Cash on hand: 7,940.01 GLP
Bank: 51,356.25 GLP
Gender: Guy
Location: Victoria, BC
Website: https://gimplearn.net
Operating System: Windows
GIMP Version: 2.8.22
My Personal Blog
My FineArtAmerica
x 1207
x 256
Contact:
Canada

Post#11 by tim » 31 May 2017, 19:58


After getting animate stack,
I just created a layer with text on top of transparent background,
ran it with the discard text info top text layer and got this error:
RuntimeError: Error: ( : 1) Procedure execution of gimp-item-is-group failed on invalid input arguments: Procedure 'gimp-item-is-group' has been called with value '-1' for argument 'item' (#1, type GimpItemID). This value is out of range.
0 x



aka Tin
Image gimplearn.net                                              

User avatar
animicule

Script Coder
View: Showcase | Slideshow
Topic Posts: 38/60
Posts: 614
Joined: 10 Jan 2017, 15:25
Cash on hand: 148.06 GLP
Bank: 56,999.00 GLP
Gender: Guy
Location: South Dakota
Operating System: Windows
GIMP Version: 2.9.5
x 169
United States of America

Post#12 by animicule » 31 May 2017, 20:30


I will investigate when I get home. Thank you for testing with AnimStack, it does contain the Unpack Layer command.
Sorry about not having a plain vanilla Gimp for checking my scripts. This is not the first time it has happened.
I will try to do better.
1 x




User avatar
animicule

Script Coder
View: Showcase | Slideshow
Topic Posts: 38/60
Posts: 614
Joined: 10 Jan 2017, 15:25
Cash on hand: 148.06 GLP
Bank: 56,999.00 GLP
Gender: Guy
Location: South Dakota
Operating System: Windows
GIMP Version: 2.9.5
x 169
United States of America

Post#13 by animicule » 31 May 2017, 20:54


I was thinking over your answer Tin..
The only reason for AnimStack is that it puts the 'script-fu-unpack-layer-group' into the pdb.
If you browse in the console for unpack-layer does it find the routine?
Oh, well I will be getting home in a few hours and be able to find out..
0 x




User avatar
tim
Administrator
View: Showcase | Slideshow
Topic Posts: 14/60
Posts: 2161
Joined: 26 Sep 2016, 00:16
Cash on hand: 7,940.01 GLP
Bank: 51,356.25 GLP
Gender: Guy
Location: Victoria, BC
Website: https://gimplearn.net
Operating System: Windows
GIMP Version: 2.8.22
My Personal Blog
My FineArtAmerica
x 1207
x 256
Contact:
Canada

Post#14 by tim » 31 May 2017, 22:10


that's not the error i was getting. I got gimp-item-is-group -1 something error.
I checked procedures and script-fu-unpack-layer-group is there.
0 x



aka Tin
Image gimplearn.net                                              

Post Reply

Last 20 Members Who Visited This Topic

User avatar PhotoMaster (2), User avatar gnerd (13), User avatar tim (2)

  • Similar Topics
    Replies
    Views
    Last post
• Featuring Members' Works (Image Attachments Only) •
1: gnerd
2: Ella
3: oldmangrumpy
4: animicule
5: gnerd
6: tim
7: trandoductin

Who is online

Users browsing this forum: No registered users and 1 guest