Page 1 of 1

Fan Illusion

Posted: 14 Mar 2019, 22:37
by Alchemist
Hello all,

Does "Fan Illusion" work in 2.10.8 this looks like it would be fun to try!

viewtopic.php?f=3&t=903&hilit=fan+illusion

Thanks for your answers, Alchemist.....

Re: Fan Illusion

Posted: 15 Mar 2019, 01:54
by tim
The link doesn't take me to fan illusion.
But if I remember correctly, that belongs to Animicule and I think he was still working with 2.8 but it might work with 2.10.

Re: Fan Illusion

Posted: 15 Mar 2019, 02:41
by Alchemist
Hi Tim,
Fixed link and I downloaded and installed it, but it doesn't even show up. No errors also, strange.
BA_FanIllusion3f4.py
(27.14 KiB) Downloaded 118 times
Later then, Alchemist.....

Re: Fan Illusion

Posted: 15 Mar 2019, 03:43
by tim
It showed up in GIMP 2.10 for me but I get errors when I run it.
And when I try to run it again the dialog doens't even show up.
Animicule hasn't checked in for 3 or 4 months now so I don't know how long before he jumps back in here to help.

Re: Fan Illusion

Posted: 17 Mar 2019, 22:22
by Alchemist
Hello Tim or anyone else who would like to chime in,

So what are the major differences between 2.8 and 2.10 that would prevent this plugin or others from working on 2.10?
With your knowledge of python would it be possible to write a plugin/script that looks for errors in plugins or scripts. NOT fix them, but do a better job than Gimp itself does at reporting errors, so I/others could possibly fix them (just wishing).

Also why would this plugin show up on your 2.10, but NOT all all on mine. I have 2.10.8 installed. Did you get a Brian menu and was it at the top or in filters. I have tried everything I can think of, but it never even shows up, strange!

Again thanks for your hard work, Alchemist.....

Re: Fan Illusion

Posted: 17 Mar 2019, 22:54
by tim
Each plug-in is different. It's hard to make something that will tell you what's wrong with a plug-in. Well there's that Constantize Plug-in that I wrote to replace GIMP 2.8 constants with GIMP 2.10 constants. That's about as far as I can go in term of automation.
I don't know why it's not showing up on menu for you. I have had other scripts that didn't show up because they weren't UTF-8 encoded but that was a Linux to Windows problem. Brian works on Windows so I don't imagine it's the same issue there.

Re: Fan Illusion

Posted: 20 Nov 2019, 01:27
by P1937
Hello Alchemist and Tin
I have Fan Illusion working in Gimp 2.10.12. Using Windows 10, 64 bit.
In the Menu at the top of the Gimp screen, Brian appears. The plugin is there.
I am using the Plugin suggested by Alchemist 15th March .
I could not get this to work in Gimp 2.10.6. So it looks like there may have been something fixed.
Good luck hope it works for others.

Re: Fan Illusion

Posted: 26 Nov 2019, 00:06
by tim
P1937 wrote:
20 Nov 2019, 01:27
Hello Alchemist and Tin
I have Fan Illusion working in Gimp 2.10.12. Using Windows 10, 64 bit.
In the Menu at the top of the Gimp screen, Brian appears. The plugin is there.
I am using the Plugin suggested by Alchemist 15th March .
I could not get this to work in Gimp 2.10.6. So it looks like there may have been something fixed.
Good luck hope it works for others.
GIMP 2.10.12 might have been fixed to recognize older GIMP's constants.