It is currently 10 Jul 2020, 12:21

• Featuring Members' Works (Image Attachments) •
1: member
2: member
3: member
4: member
5: member

GIMP/GL:  Tutorials | Tips | 🡆 Questions | Interests | Script Requests
Recommendations:  Index | Top 10
Resources:  Python-Fu Plug-ins | Scheme-Fu Scripts | GIMP
Python:  Lessons | Questions | Exercises
The Arts:  GIMPed | GIMPed Photos | Other | Contests | Public Domain Images | Isolated Images | Blender
Inkscape
Social:  Say Hello | Anything Goes | Shares | FCSP

Link to Layer Effects Download

GIMP or GIMP LEARN forum related Questions
VLynn
Forum Member

Link to Layer Effects Download

Post#1 by VLynn » 31 Mar 2019, 23:47


I have been looking and looking but cannot find a good link to download the Layer Effects for Gimp 2.8 / 2.10. I am needing the Bevel & Emboss feature. I downloaded a FX-Foundry a few months back, but several plug-ins in this doesn't work correctly.
The message I get when trying to use Bevel & Emboss is: Plug-in 'Bevel and Emboss' left image undo in inconsistent state, closing open undo groups. ... & Error while executing script-fu-layer-effects-bevel-and-emboss:
Error: eval: unbound variable: WHITE-MASK

Can ANYONE help me get this plug-in working correctly... or direct me to a Link where I can download the correct version for it? Thank You

Vicki Lynn
GIMP Learn rocks...
0

Wallace
Global Moderator

Post#2 by Wallace » 01 Apr 2019, 01:29


VLynn wrote:
31 Mar 2019, 23:47
I have been looking and looking but cannot find a good link to download the Layer Effects for Gimp 2.8 / 2.10. I am needing the Bevel & Emboss feature. I downloaded a FX-Foundry a few months back, but several plug-ins in this doesn't work correctly.
The message I get when trying to use Bevel & Emboss is: Plug-in 'Bevel and Emboss' left image undo in inconsistent state, closing open undo groups. ... & Error while executing script-fu-layer-effects-bevel-and-emboss:
Error: eval: unbound variable: WHITE-MASK

Can ANYONE help me get this plug-in working correctly... or direct me to a Link where I can download the correct version for it? Thank You

Vicki Lynn
You can try the .py or the .scm file.
I have them both installed in Gimp 2.8.18 and they work.
Don't know if they work in 2.10.
layerfx.2.8.py
(270.28 KiB) Downloaded 352 times
layerfx.scm
(55.46 KiB) Downloaded 494 times
Image
0

tim
GL Blogger

Post#3 by tim » 01 Apr 2019, 02:01


Wallace's copy works in my GIMP 2.10.8,
but you never know as there have been cases where CONSTANTS are not understood in other GIMP 2.10 installations. If that's the case let me know what the error is exactly I'll look into finding out what constant needs changing manually (since my CONSTANTIZE script broke the script).
layerfx.py
Try this one if it, I have changed the constants that I think I needed changing for GIMP 2.10 This should take care of the ADD_WHITE_MASK error others might show up/need changing but I can't test that on mine because my GIMP 2.10 recognizes all the GIMP 2.8 constants.
(270.3 KiB) Downloaded 207 times
aka Tin
:tree_02:
Tin's: Favorite Index | Simple Art === fb4yt video search | fb4yt recent video views report
Lottery numbers from image | Interested Members in TLF
Paying for hosting is to support my hobby, and donating money made from ads to The Red Cross.
         
0

VLynn
Forum Member

Post#4 by VLynn » 01 Apr 2019, 18:24


Okay, now I seem to have it Downloaded and I am experiencing an "unbound variable" ... including image of Error message.
And THANK YOU both for your help!!!
Attachments
Layer Emboss Error.PNG
Layer Emboss Error.PNG (99.91 KiB) Viewed 3805 times
GIMP Learn rocks...
0

tim
GL Blogger

Post#5 by tim » 01 Apr 2019, 18:29


That's odd I don't understand where that WHITE-MASK error is coming from since I renamed the constant in my version to ADD_MASK_WHITE.

UPDATE: Are you using a .scm? since that looks like a .scm variable name because in python (.py files) everything is named as underscores, not hyphens.
I suggest you try removing or move the .scm file to somewhere else outside of /scripts/ folder and just try my .py version in /plug-ins/ folder.
aka Tin
:tree_02:
Tin's: Favorite Index | Simple Art === fb4yt video search | fb4yt recent video views report
Lottery numbers from image | Interested Members in TLF
Paying for hosting is to support my hobby, and donating money made from ads to The Red Cross.
         
0

VLynn
Forum Member

Post#6 by VLynn » 04 Apr 2019, 02:53


Tim... I did try using the .py version first.. but had downloaded it from a different site. I will delete it and try just using the one you posted and see what happens.
GIMP Learn rocks...
0

tim
GL Blogger

Post#7 by tim » 04 Apr 2019, 03:04


The .py version shouldn't give you a constant names that has hyphens in them, only underscores. Unless you have a .scm and .py installed and so when you run it from the front end you can't tell if you're running the .scm or the .py. That's why I suggested you move or delete the .scm (so that it doesn't show up at all in GIMP and that way you know you're running the .py).

UPDATE: also look at your error mesage it says script-fu and not python-fu which means you're running the .scm from front end and not .py.
aka Tin
:tree_02:
Tin's: Favorite Index | Simple Art === fb4yt video search | fb4yt recent video views report
Lottery numbers from image | Interested Members in TLF
Paying for hosting is to support my hobby, and donating money made from ads to The Red Cross.
         
0


GIMP/GL:  Tutorials | Tips | 🡆 Questions | Interests | Script Requests
Recommendations:  Index | Top 10
Resources:  Python-Fu Plug-ins | Scheme-Fu Scripts | GIMP
Python:  Lessons | Questions | Exercises
The Arts:  GIMPed | GIMPed Photos | Other | Contests | Public Domain Images | Isolated Images | Blender
Inkscape
Social:  Say Hello | Anything Goes | Shares | FCSP

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 2 guests